summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-10 13:14:15 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 16:40:29 +0200
commit344316b455345485dfd60baaa88105599467fe9b (patch)
tree8471fa577bddfe08790a25ed94a6814954cb00e6 /gnu/packages/xorg.scm
parentda40d07066096a3b5a852041ea01fbb32240deda (diff)
downloadguix-patches-344316b455345485dfd60baaa88105599467fe9b.tar
guix-patches-344316b455345485dfd60baaa88105599467fe9b.tar.gz
gnu: xvfb-run: Fix ‘xvfb-run --help’ in a pure environment.
* gnu/packages/xorg.scm (xvfb-run)[arguments]: Refer to ‘cat’ by absolute file name, and test whether ‘xvfb-run --help’ succeeds in a pure environment in the ‘check’ phase. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 45001309be..6a7849f8c6 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6878,7 +6879,7 @@ box, and a calendar. It uses GTK+, and will match your desktop theme.")
(lambda _
(chmod "xvfb-run" #o755)
(substitute* "xvfb-run"
- (("(\\(| )(fmt|stty|awk|kill|getopt|mktemp|touch|rm|mcookie)"
+ (("(\\(| )(fmt|stty|awk|cat|kill|getopt|mktemp|touch|rm|mcookie)"
_ prefix command)
(string-append prefix (which command)))
;; These also feature in UI messages, so be more strict.
@@ -6887,13 +6888,15 @@ box, and a calendar. It uses GTK+, and will match your desktop theme.")
(string-append prefix (which command))))))
(replace 'check
;; There are no tests included. Here we test whether we can run
- ;; a simple client without xvfb-run itself relying on $PATH.
+ ;; a simple client and whether xvfb-run --help succeeds
+ ;; without xvfb-run itself relying on $PATH.
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(let ((old-PATH (getenv "PATH"))
(xterm (which "xterm")))
(unsetenv "PATH")
(invoke "./xvfb-run" xterm "-e" "true")
+ (invoke "./xvfb-run" "--help")
(setenv "PATH" old-PATH)))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)