summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-07 21:27:36 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-07 23:25:22 +0200
commit95288fcc6cfa184b500caa95062bf3194d255880 (patch)
treefd79c02f1c88a331b7a7678ae20bbf20185b2e8f /gnu/packages/xorg.scm
parent0d56e3e1bc7269c403c72ba265cec44d4757d1a1 (diff)
downloadguix-patches-95288fcc6cfa184b500caa95062bf3194d255880.tar
guix-patches-95288fcc6cfa184b500caa95062bf3194d255880.tar.gz
gnu: python: Add "minimal" variants.
* gnu/packages/python.scm (python2-minimal, python-minimal): New variables. (wrap-python3): New procedure. (python-wrapper): Use it. (python-minimal-wrapper): New variable. * gnu/packages/xml.scm (libxslt)[native-inputs]: Use PYTHON-MINIMAL-WRAPPER instead of PYTHON-WRAPPER. * gnu/packages/xorg.scm (xcb-proto, libxcb, xorg-server): Likewise.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d4ed4b82d0..47dc0e2601 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2050,7 +2050,7 @@ legacy X clients.")
"0bp3f53l9fy5x3mn1rkj1g81aiyzl90wacwvqdgy831aa3kfxb5l"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config) ("python" ,python-wrapper)))
+ `(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
(home-page "http://www.x.org/wiki/")
(synopsis "XML-XCB protocol descriptions")
(description
@@ -4804,7 +4804,7 @@ protocol.")
("libxslt" ,libxslt)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
+ ("python" ,python-minimal-wrapper)))
(arguments
`(#:configure-flags '("--enable-xkb")))
(home-page "http://www.x.org/wiki/")
@@ -4889,7 +4889,7 @@ over Xlib, including:
("xtrans" ,xtrans)
("zlib" ,zlib)))
(native-inputs
- `(("python" ,python-wrapper)
+ `(("python" ,python-minimal-wrapper)
("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f