summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-30 12:01:32 +0200
committerLudovic Courtès <ludo@gnu.org>2016-09-30 12:05:27 +0200
commit79355ae3e84359716f5135cc7083e72246bc8bf9 (patch)
tree6b61851e2153581578bb78ef0f177b8841ee5db7 /gnu/packages/xorg.scm
parent39d6b9c99f297e14fc4f47f002be3d40556726be (diff)
parent86d8f6d3efb8300a3354735cbf06be6c01e23243 (diff)
downloadguix-patches-79355ae3e84359716f5135cc7083e72246bc8bf9.tar
guix-patches-79355ae3e84359716f5135cc7083e72246bc8bf9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index aafb781ddf..00f975bf65 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2016 David Craven <david@craven.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
@@ -5169,6 +5171,23 @@ communicates with the user via graphical controls such as buttons and
draggable titlebars and borders.")
(license license:x11)))
+(define-public xorg-server-xwayland
+ (package
+ (inherit xorg-server)
+ (name "xorg-server-xwayland")
+ (inputs
+ `(("libepoxy" ,libepoxy)
+ ("wayland" ,wayland)
+ ,@(package-inputs xorg-server)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments xorg-server)
+ ((#:configure-flags flags)
+ `(cons* "--enable-xwayland" "--disable-xorg"
+ "--disable-docs" "--disable-devel-docs"
+ "--disable-xvfb" "--disable-xnest"
+ "--disable-xquartz" "--disable-xwin"
+ ,flags))))
+ (synopsis "Xorg server with wayland backend")))
;; packages of height 4 in the propagated-inputs tree