summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-08 22:26:38 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-08 23:06:27 +0100
commit4b797193d7508ddc53bb1ff7a267a0d50c1fe298 (patch)
tree53d14b50eda0e4666d6fa13c2a11dfc949af1ccd /gnu/packages/xorg.scm
parent49a09ea9e52d24bf27d854ececa9202c2a9705c5 (diff)
downloadguix-patches-4b797193d7508ddc53bb1ff7a267a0d50c1fe298.tar
guix-patches-4b797193d7508ddc53bb1ff7a267a0d50c1fe298.tar.gz
gnu: libxi: Add "doc" output.
* gnu/packages/xorg.scm (libxi)[outputs]: New field. [arguments]: Pass "--mandir".
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 24b7d6f1e5..e1523c25eb 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5156,8 +5156,12 @@ new API's in libXft, or the legacy API's in libX11.")
(base32
"0q8hz3slga3w3ch8wp0k7ay9ilhz315qnab0w1y2x9w3cf7hv8rn"))))
(build-system gnu-build-system)
+ (outputs '("out" "doc")) ;man pages represent 28% of the total
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:configure-flags (list "--disable-static"
+ (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man"))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libx11" ,libx11)