summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-06-26 18:43:22 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:54 +0200
commitd7c53647323963ec656852a5b967f3e3792b99c3 (patch)
treeba799ee56037243dc9a5890fc44076c544b6b87e /gnu/packages/xorg.scm
parentda66bd38572840eb56a11e8cf3093bd811992eb5 (diff)
downloadguix-patches-d7c53647323963ec656852a5b967f3e3792b99c3.tar
guix-patches-d7c53647323963ec656852a5b967f3e3792b99c3.tar.gz
gnu: xorg: Fix cross-compilation of multiple packages.
* gnu/packages/xorg.scm (libxext)[arguments]: Disable zero malloc check that fails when cross-compiling, (libxrender)[arguments]: ditto, (libx11)[arguments]: ditto.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm28
1 files changed, 24 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b3d9fd3cb7..d7cd585664 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4552,6 +4552,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0azqxllcsfxc3ilhz6kwc6x7m8wc477p59ir9p0yrsldx766zbar"))))
(build-system gnu-build-system)
+ ;; Disable zero malloc check that fails when cross-compiling.
+ (arguments
+ `(#:configure-flags
+ (list
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -4637,6 +4644,13 @@ cannot be adequately worked around on the client side of the wire.")
(base32
"0j89cnb06g8x79wmmnwzykgkkfdhin9j7hjpvsxwlr3fz1wmjvf0"))))
(build-system gnu-build-system)
+ ;; Disable zero malloc check that fails when cross-compiling.
+ (arguments
+ `(#:configure-flags
+ (list
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)))
(inputs
@@ -5245,16 +5259,22 @@ draggable titlebars and borders.")
(outputs '("out"
"doc")) ;8 MiB of man pages + XML
(arguments
- '(#:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "doc")
- "/share/man"))))
+ `(#:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "doc")
+ "/share/man")
+ ;; Disable zero malloc check that fails when cross-compiling.
+ ,@(if (%current-target-system)
+ '("--disable-malloc0returnsnull")
+ '()))))
(propagated-inputs
`(("xorgproto" ,xorgproto)
("libxcb" ,libxcb)))
(inputs
`(("xtrans" ,xtrans)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("xorgproto" ,xorgproto)))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg Core X11 protocol client library")
(description "Xorg Core X11 protocol client library.")