summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-09-23 23:49:42 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-27 18:36:00 +0000
commit38df0c033403a6ce9d330ae32a551a81ef44a822 (patch)
treef221abe923ff3daa971674785d63d5889dc29188 /gnu/packages/xorg.scm
parent4b339c7e3d43fb6f742a391f55908bd796b94ac7 (diff)
downloadguix-patches-38df0c033403a6ce9d330ae32a551a81ef44a822.tar
guix-patches-38df0c033403a6ce9d330ae32a551a81ef44a822.tar.gz
gnu: libxvmc: Pass --disable-malloc0returnsnull when cross-compiling.
This fixes a configure error when cross-compiling and doesn't cause any rebuilds. * gnu/packages/xorg.scm (libxvmc)[arguments]<#:configure-flags>: Add malloc0flags. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f53962d618..92706c0240 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5272,7 +5272,7 @@ new API's in libXft, or the legacy API's in libX11.")
"1kbdjsvkm5l7axv7g477qj18sab2wnqhliy6197syzizgfbsfgbb"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ `(#:configure-flags '(,@(malloc0-flags) "--disable-static")))
(propagated-inputs
`(("libxv" ,libxv)))
(inputs