summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
commit7be1a73ea2cb5350c52809e8524faeb2dfdd860f (patch)
tree0f5a0d2f21de5416e2396cecb3d7d67499936e7d /gnu/packages/xml.scm
parent3fae4f64bafee61d335e42aa83a112328654f329 (diff)
downloadguix-patches-7be1a73ea2cb5350c52809e8524faeb2dfdd860f.tar
guix-patches-7be1a73ea2cb5350c52809e8524faeb2dfdd860f.tar.gz
gnu: xlsxio: Remove ad hoc 'install phase.
* gnu/packages/xml.scm (xlsxio)[arguments]: Use #:make-flags instead of an ad hoc 'install phase.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 855d2b3d47..584acd2131 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1532,15 +1532,12 @@ SAX2 APIs.")
(build-system gnu-build-system)
(arguments
(list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
- (delete 'check)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "make" "install"
- (string-append
- "PREFIX=" (assoc-ref outputs "out"))))))))
+ (delete 'check))))
(synopsis "C library for reading and writing .xlsx files")
(description "XLSX I/O aims to provide a C library for reading and writing
.xlsx files. The .xlsx file format is the native format used by Microsoft(R)