summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-15 10:09:22 +0000
committerKei Kebreau <kei@openmailbox.org>2017-04-08 12:40:06 -0400
commitd2b51c08fdf646822e038c520302af8e98583adf (patch)
tree8d0481b77e2207ef411e5e47ad908ec80bc6a905 /gnu/packages/xml.scm
parent72fa66674d17bdf6acef87665295e604c56c15e9 (diff)
downloadguix-patches-d2b51c08fdf646822e038c520302af8e98583adf.tar
guix-patches-d2b51c08fdf646822e038c520302af8e98583adf.tar.gz
gnu: Add python-defusedxml.
* gnu/packages/xml.scm (python-defusedxml): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b2e8959df0..283d5112ae 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;;
@@ -1068,3 +1068,24 @@ XSLT and EXSLT.")
XLSM) format spreadsheets into plaintext @dfn{comma separated values} (CSV)
files. It is designed to be fast and to handle large input files.")
(license license:gpl2+)))
+
+(define-public python-defusedxml
+ (package
+ (name "python-defusedxml")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "defusedxml" version))
+ (sha256
+ (base32
+ "0y147zy3jqmk6ly7fbhqmzn1hf41xcb53f2vcc3m8x4ba5d1smfd"))))
+ (build-system python-build-system)
+ (home-page "https://bitbucket.org/tiran/defusedxml")
+ (synopsis "XML bomb protection for Python stdlib modules")
+ (description
+ "Defusedxml provides XML bomb protection for Python stdlib modules.")
+ (license license:psfl)))
+
+(define-public python2-defusedxml
+ (package-with-python2 python-defusedxml))