summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
commitf056553c6b8ffa36f4ce9fb1c3602a8f4b1de242 (patch)
tree80c815216a3717cf00b615c9cb8840c113eaf79f /gnu/packages/xml.scm
parent2c9d34166983565120f831284df57a07e2edd2f9 (diff)
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadguix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar
guix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm14
1 files changed, 2 insertions, 12 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index d0216423e8..ba7c121776 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -1017,28 +1017,18 @@ Libxml2).")
(name "minixml")
(version "2.12")
(source (origin
- (method url-fetch/tarbomb)
+ (method url-fetch)
(uri (string-append "https://github.com/michaelrsweet/mxml/"
"releases/download/v" version
"/mxml-" version ".tar.gz"))
(sha256
(base32
- "1z8nqxa4pqdic8wpixkkgg1m2pak9wjikjjxnk3j5i0d29dbgmmg"))))
+ "0kq3wiycb40dcyswvajrqb1n5ffm5xcnsfxxaml92vhpl6x57yvb"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
(list (string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-permissions
- ;; FIXME: url-fetch/tarbomb resets all permissions to 555/444.
- (lambda _
- (for-each
- (lambda (file)
- (chmod file #o644))
- (find-files "doc" "\\."))
- #t)))
#:tests? #f)) ; tests are run during build
(home-page "https://michaelrsweet.github.io/mxml")
(synopsis "Small XML parsing library")