summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-06-18 02:38:43 -0400
committerMark H Weaver <mhw@netris.org>2017-06-18 02:41:58 -0400
commit05e26d1ecd41bdac5ef531b9f6f5c0c6bfbf3a30 (patch)
tree3e1fd116832cf62a6ea4f62dd499003edff66a75 /gnu/packages/xml.scm
parent9d4385634d098cc0fb35bfe58179f7d855352e39 (diff)
downloadguix-patches-05e26d1ecd41bdac5ef531b9f6f5c0c6bfbf3a30.tar
guix-patches-05e26d1ecd41bdac5ef531b9f6f5c0c6bfbf3a30.tar.gz
gnu: expat: Eliminate graft.
* gnu/packages/xml.scm (expat): Update to 2.2.1. [source]: Remove patch. [replacement]: Remove field. (expat-2.2.1): Remove variable. * gnu/packages/patches/expat-CVE-2016-0718-fix-regression.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index a6bea3588fe..4ed45508fd2 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -55,17 +55,14 @@
(define-public expat
(package
(name "expat")
- (version "2.2.0")
- (replacement expat-2.2.1)
+ (version "2.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/expat/expat/"
version "/expat-" version ".tar.bz2"))
- (patches
- (search-patches "expat-CVE-2016-0718-fix-regression.patch"))
(sha256
(base32
- "1zq4lnwjlw8s9mmachwfvfjf2x3lk24jm41746ykhdcvs7r0zrfr"))))
+ "11c8jy1wvllvlk7xdc5cm8hdhg0hvs8j0aqy6s702an8wkdcls0q"))))
(build-system gnu-build-system)
(home-page "http://www.libexpat.org/")
(synopsis "Stream-oriented XML parser library written in C")
@@ -75,19 +72,6 @@ stream-oriented parser in which an application registers handlers for
things the parser might find in the XML document (like start tags).")
(license license:expat)))
-(define expat-2.2.1 ; Fixes CVE-2017-9233, CVE-2016-9063 and other issues.
- (package
- (inherit expat)
- (version "2.2.1")
- (replacement #f)
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/expat/expat/"
- version "/expat-" version ".tar.bz2"))
- (sha256
- (base32
- "11c8jy1wvllvlk7xdc5cm8hdhg0hvs8j0aqy6s702an8wkdcls0q"))))))
-
(define-public libxml2
(package
(name "libxml2")