summaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:13:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:46 +0300
commitb33c255d4db6a1e5d278629d9fbc508a73726d37 (patch)
tree145b0597044678afff8a3b62f265c2fc24d22384 /gnu/packages/xml.scm
parent3651c4714e52cfb1b0e2e98825d5f754a3a06eab (diff)
downloadguix-patches-b33c255d4db6a1e5d278629d9fbc508a73726d37.tar
guix-patches-b33c255d4db6a1e5d278629d9fbc508a73726d37.tar.gz
gnu: expat: Update to 2.2.2.
* gnu/packages/xml.scm (expat): Update to 2.2.2. [replacement]: Remove field. (expat-2.2.2): Remove variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index ff9862e4b9..44102e836b 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -56,15 +56,14 @@
(define-public expat
(package
(name "expat")
- (version "2.2.1")
- (replacement expat-2.2.2)
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/expat/expat/"
version "/expat-" version ".tar.bz2"))
(sha256
(base32
- "11c8jy1wvllvlk7xdc5cm8hdhg0hvs8j0aqy6s702an8wkdcls0q"))))
+ "0ik0r39ala9c6hj4kxrk933klgwkzlkbrfhvhaykx8l1rwgr2xj3"))))
(build-system gnu-build-system)
(home-page "http://www.libexpat.org/")
(synopsis "Stream-oriented XML parser library written in C")
@@ -74,18 +73,6 @@ stream-oriented parser in which an application registers handlers for
things the parser might find in the XML document (like start tags).")
(license license:expat)))
-(define expat-2.2.2 ; Fixes CVE-2017-9233, CVE-2016-9063 and other issues.
- (package
- (inherit expat)
- (version "2.2.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/expat/expat/"
- version "/expat-" version ".tar.bz2"))
- (sha256
- (base32
- "0ik0r39ala9c6hj4kxrk933klgwkzlkbrfhvhaykx8l1rwgr2xj3"))))))
-
(define-public libebml
(package
(name "libebml")