summaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-30 21:17:43 +0800
committer宋文武 <iyzsong@gmail.com>2015-09-02 19:44:33 +0800
commit0f0c586a076208be53eff3c70f8ce42bca17a614 (patch)
tree4d289b8effb644f4485194b6c215edf382efc07f /gnu/packages/xfce.scm
parent7ee2005ede4ca38b8dcc40f4b11ad716a965aec5 (diff)
downloadguix-patches-0f0c586a076208be53eff3c70f8ce42bca17a614.tar
guix-patches-0f0c586a076208be53eff3c70f8ce42bca17a614.tar.gz
gnu: Add xfce4-pulseaudio-plugin.
* gnu/packages/xfce.scm (xfce4-pulseaudio-plugin): New variable.
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index bc6d47a92a..bdb5235880 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -38,7 +38,8 @@
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages linux)
#:use-module (gnu packages photo)
- #:use-module (gnu packages pcre))
+ #:use-module (gnu packages pcre)
+ #:use-module (gnu packages pulseaudio))
(define-public gtk-xfce-engine
(package
@@ -352,6 +353,37 @@ handle text and images, and has a feature to execute actions on specific text by
matching them against regular expressions.")
(license (list gpl2+))))
+(define-public xfce4-pulseaudio-plugin
+ (package
+ (name "xfce4-pulseaudio-plugin")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0crvb2gyxbnlf46712arg3m2vqx81dixqhqdwss0bngpijy3ca78"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("exo" ,exo)
+ ("libnotify" ,libnotify)
+ ("libxfce4ui" ,libxfce4ui)
+ ("pulseaudio" ,pulseaudio)
+ ("xfce4-panel" ,xfce4-panel)))
+ (home-page "http://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
+ (synopsis "PulseAudio panel plugin for Xfce")
+ (description
+ "Xfce PulseAudio plugin is a plugin for the Xfce panel which provides a
+convenient way to adjust the audio volume of the PulseAudio sound system and
+to an auto mixer tool like pavucontrol. It can optionally handle multimedia
+keys for controlling the audio volume.")
+ (license gpl2+)))
+
(define-public xfce4-appfinder
(package
(name "xfce4-appfinder")