summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2015-04-18 22:42:00 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-18 22:57:52 +0200
commitf1f7049ec1f4b94fcf83ba68dcaab011280e7cb9 (patch)
tree0b2e1b24b71117064a3e08f3235d0a866c0bafc1 /gnu/packages/xdisorg.scm
parent724311a26b5205dd5721439389ab70aab4082371 (diff)
downloadguix-patches-f1f7049ec1f4b94fcf83ba68dcaab011280e7cb9.tar
guix-patches-f1f7049ec1f4b94fcf83ba68dcaab011280e7cb9.tar.gz
gnu: Add libwacom.
* gnu/packages/xdisorg.scm (libwacom): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bf15b38f09..9e240db6c5 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015 Alexander I.Grafov <grafov@gmail.com>
+;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (guix download)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages image)
@@ -36,6 +38,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages linux)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages xorg))
;; packages outside the x.org system proper
@@ -527,3 +531,32 @@ within a single process.")
pressed and released on its own. The default behaviour is to generate the
Escape key when Left Control is pressed and released on its own.")
(license license:gpl3+)))
+
+(define-public libwacom
+ (package
+ (name "libwacom")
+ (version "0.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/linuxwacom/libwacom/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "022d0097dk2glgb6772zpcsqm1w42sbsbr3i72pdhzq6naqawys8"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("eudev" ,eudev)
+ ("libxml2" ,libxml2)))
+ (home-page "http://linuxwacom.sourceforge.net/")
+ (synopsis "Helper library for Wacom tablet settings")
+ (description
+ "Libwacom is a library to help implement Wacom tablet settings. It
+is intended to be used by client-programs that need model identification. It
+is already being used by the gnome-settings-daemon and the GNOME 3.4 Control
+Center Wacom tablet applet. In the future, the xf86-input-wacom driver may
+use it as well.")
+ (license license:x11)))