summaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2015-12-06 21:58:03 +0100
committerMathieu Lirzin <mthl@gnu.org>2015-12-21 13:35:34 +0100
commit1ef3f91a702e19b01aff2e85b7ea2abe1f7579a1 (patch)
treeba94d6f6750b168106908a125de94fe78a928240 /gnu/packages/xdisorg.scm
parent72d8b5baf414215e8b115364a2d4fd188053f78b (diff)
downloadguix-patches-1ef3f91a702e19b01aff2e85b7ea2abe1f7579a1.tar
guix-patches-1ef3f91a702e19b01aff2e85b7ea2abe1f7579a1.tar.gz
gnu: rxvt-unicode: Install the terminal capability data.
This provides the necessary terminal capability data, which are required by ncurses-based applications. * gnu/packages/xdisorg.scm (rxvt-unicode)[native-inputs]: Add ncurses. [arguments]: Set the destination of the terminfo files. [native-search-path]: New field. Make them automatically available to the user.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm35
1 files changed, 23 insertions, 12 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index efe858615d..0b1eb20238 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome) ;for libgudev
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module (gnu packages linux)
@@ -530,24 +531,34 @@ compact configuration syntax.")
(package
(name "rxvt-unicode")
(version "9.21")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://dist.schmorp.de/rxvt-unicode/"
- name "-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "0swmi308v5yxsddrdhvi4cch88k2bbs2nffpl5j5m2f55gbhw9vm"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://dist.schmorp.de/rxvt-unicode/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0swmi308v5yxsddrdhvi4cch88k2bbs2nffpl5j5m2f55gbhw9vm"))))
(build-system gnu-build-system)
+ (arguments
+ ;; This sets the destination when installing the necessary terminal
+ ;; capability data, which are not provided by 'ncurses'. See
+ ;; https://lists.gnu.org/archive/html/bug-ncurses/2009-10/msg00031.html
+ '(#:make-flags (list (string-append "TERMINFO="
+ (assoc-ref %outputs "out")
+ "/share/terminfo"))))
(inputs
`(("libXft" ,libxft)
("libX11" ,libx11)))
(native-inputs
- `(("perl" ,perl)
+ `(("ncurses" ,ncurses) ;trigger the installation of terminfo data
+ ("perl" ,perl)
("pkg-config" ,pkg-config)))
+ ;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
+ ;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TERMINFO_DIRS")
+ (files '("share/terminfo")))))
(home-page "http://software.schmorp.de/pkg/rxvt-unicode.html")
(synopsis "Rxvt clone with XFT and unicode support")
(description "Rxvt-unicode (urxvt) is a colour vt102 terminal emulator