summaryrefslogtreecommitdiff
path: root/gnu/packages/wxwidgets.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-01 13:59:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-05-01 17:13:53 -0400
commit39ba8a10971f15264966823e8696d63c2995df86 (patch)
tree24760456ca1b1082985a0313a49d7d09a6dbe17c /gnu/packages/wxwidgets.scm
parentf21007ce4aceeacf5bbfc7cd45d526073141f194 (diff)
downloadguix-patches-39ba8a10971f15264966823e8696d63c2995df86.tar
guix-patches-39ba8a10971f15264966823e8696d63c2995df86.tar.gz
gnu: python-wxpython: Apply patch to fix TypeError exceptions.
This is caused by Python 3.10's new behavior of native extension now rejecting float values as input when the expected type is an integer. * gnu/packages/patches/python-wxwidgets-type-errors.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/wxwidgets.scm (python-wxpython) [source]: Apply it. Delete trailing #t. [arguments]: Delete trailing #t.
Diffstat (limited to 'gnu/packages/wxwidgets.scm')
-rw-r--r--gnu/packages/wxwidgets.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/wxwidgets.scm b/gnu/packages/wxwidgets.scm
index b226aa4e83..5415f47f55 100644
--- a/gnu/packages/wxwidgets.scm
+++ b/gnu/packages/wxwidgets.scm
@@ -276,8 +276,8 @@ and many other languages.")
(snippet
'(begin
;; Remove bundled wxwidgets
- (delete-file-recursively "ext/wxWidgets")
- #t))))
+ (delete-file-recursively "ext/wxWidgets")))
+ (patches (search-patches "python-wxwidgets-type-errors.patch"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -300,8 +300,7 @@ and many other languages.")
(chmod "demo/version.py" #o644)
;; Build only the python bindings, not wxwidgets also.
(substitute* "setup.py"
- (("'build']") "'build_py', '--use_syswx']"))
- #t)))))
+ (("'build']") "'build_py', '--use_syswx']")))))))
(inputs
(list gtk+ wxwidgets))
(native-inputs