summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-11-04 15:55:08 -0400
committerChristopher Baines <mail@cbaines.net>2023-11-05 17:57:56 +0000
commitbf6fdf76b0fe19cbf5787795caac8edab6eeb439 (patch)
tree3fad444b91df4ab03346711217e67b14699026a3 /gnu/packages/wm.scm
parenta482d3d9ba41c914de1a08ac0ef71406925b8a19 (diff)
downloadguix-patches-bf6fdf76b0fe19cbf5787795caac8edab6eeb439.tar
guix-patches-bf6fdf76b0fe19cbf5787795caac8edab6eeb439.tar.gz
gnu: Remove dunst.scm.
The dunst package is much beter suited to be in wm.scm. This patch deletes dunst.scm, moves dunst to wm.scm, and removes dunst.scm from the build process. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove dunst.scm. * gnu/packages/dunst.scm: Delete file. * gnu/packages/wm.scm (dunst): New variable. Change-Id: I3b074f12f34e14ef1101069ed45ddb33f8d3ea51 Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c3a6b31c84..95d2a879bc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2023 Jonathan Brielamier <jonathan.brielmaier@web.de>
;;; Copyright © 2023 Vessel Wave <vesselwave@disroot.org>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1490,6 +1491,56 @@ It is inspired by Xmonad and dwm. Its major features include:
project derived from the original Calm Window Manager.")
(license license:isc)))
+(define-public dunst
+ (package
+ (name "dunst")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dunst-project/dunst")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17zrw7jrnlyln81pxw7p4jgvl7j1w1gf488nfskhns6j6dcz90gh"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no check target
+ #:make-flags #~(list (string-append "CC="
+ #$(cc-for-target))
+ (string-append "PREFIX=" %output)
+ (string-append "SYSCONFDIR=" %output "/etc")
+ ;; Otherwise it tries to install service file
+ ;; to "dbus" store directory.
+ (string-append "SERVICEDIR_DBUS=" %output
+ "/share/dbus-1/services")
+ "dunstify")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list pkg-config perl ;for pod2man
+ which))
+ (inputs (list dbus
+ (librsvg-for-system) ;for svg support
+ glib
+ cairo
+ pango
+ libnotify ;for dunstify
+ libx11
+ libxscrnsaver
+ libxinerama
+ libxrandr
+ libxdg-basedir
+ wayland)) ;for wayland support
+ (home-page "https://dunst-project.org/")
+ (synopsis "Customizable and lightweight notification daemon")
+ (description
+ "Dunst is a highly configurable and minimalistic notification daemon.
+It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
+started automatically on the first call via D-Bus.")
+ (license license:bsd-3)))
+
(define-public dwl
(package
(name "dwl")