summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorEuAndreh via Guix-patches via <guix-patches@gnu.org>2020-08-08 06:24:21 -0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-14 15:33:40 +0300
commit9c814c337946f5e70b0dbe45fb54f451b06fe0b2 (patch)
treeced924f3b7118b6d9c657fca0e2fc80b56f29e21 /gnu/packages/wm.scm
parent8b3b19881b71f2031372736b9071b0bbb1c184d2 (diff)
downloadguix-patches-9c814c337946f5e70b0dbe45fb54f451b06fe0b2.tar
guix-patches-9c814c337946f5e70b0dbe45fb54f451b06fe0b2.tar.gz
gnu: Add yeganesh.
* gnu/packages/wm.scm (yeganesh): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index a1036654aa..28c3a3bac6 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Boris A. Dekshteyn <harlequin78@gmail.com>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -743,6 +744,29 @@ is also usable with any other window manager. While xmobar is written in
Haskell, no knowledge of the language is required to install and use it.")
(license license:bsd-3)))
+(define-public yeganesh
+ (package
+ (name "yeganesh")
+ (version "2.4")
+ (source
+ (origin
+
+ (method url-fetch)
+ (uri (string-append "http://dmwit.com/yeganesh/yeganesh-" version ".tar.gz"))
+ (sha256
+ (base32 "04djfyjab3c5y9z9x8zd0xcx0jyy35zq7cl9ddr4ppf6k5ky6iky"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-strict" ,ghc-strict)
+ ("ghc-xdg-basedir" ,ghc-xdg-basedir)))
+ (home-page "http://dmwit.com/yeganesh/")
+ (synopsis "Small wrapper around dmenu")
+ (description "@code{yeganesh} is a small wrapper around demnu. Like
+dmenu, it accepts input on stdin and writes the chosen result on stdout.
+Unlike dmenu, it mangles the input before it presents its choices. In
+particular, it displays commonly-chosen options before uncommon ones.")
+ (license license:bsd-3)))
+
(define-public ghc-xmonad-contrib
(package
(name "ghc-xmonad-contrib")