summaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-21 11:40:30 +0800
committerLudovic Courtès <ludo@gnu.org>2021-06-23 23:35:27 +0200
commit57d4fc7b1aeb11540ffdda8d49a244244514d3e4 (patch)
tree94424fd1bc4c7373290bebc475d3d8a398c3c8ac /gnu/packages/wm.scm
parent2bb789f6e0501ad6dc9e6fbc8f9502680a5725b1 (diff)
downloadguix-patches-57d4fc7b1aeb11540ffdda8d49a244244514d3e4.tar
guix-patches-57d4fc7b1aeb11540ffdda8d49a244244514d3e4.tar.gz
gnu: Add fnott.
* gnu/packages/wm.scm (fnott): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c7a1c5a7ac..c686a70b93 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -82,6 +82,7 @@
#:use-module (gnu packages bison)
#:use-module (gnu packages build-tools) ;for meson-0.55
#:use-module (gnu packages calendar)
+ #:use-module (gnu packages datastructures)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
@@ -908,6 +909,41 @@ experience.")
(home-page "http://fluxbox.org/")
(license license:expat)))
+(define-public fnott
+ (package
+ (name "fnott")
+ (version "1.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/dnkl/fnott")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13a0hb4wdbdlshzsj2r0d5zzvcy1jzs1hixm016n8bq7scjlvl2k"))))
+ (build-system meson-build-system)
+ (arguments
+ `( #:meson ,meson-0.55
+ #:build-type "release"))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("wayland-protocols" ,wayland-protocols)
+ ("tllist" ,tllist)
+ ("gcc" ,gcc-10) ;TODO: Remove when the default compiler is > GCC 7.
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("wlroots" ,wlroots)
+ ("wayland" ,wayland)
+ ("fcft" ,fcft)
+ ("dbus" ,dbus)
+ ("libpng" ,libpng)))
+ (home-page "https://codeberg.org/dnkl/fnott")
+ (synopsis "Keyboard driven and lightweight Wayland notification daemon")
+ (description "Fnott is a keyboard driven and lightweight notification daemon
+for wlroots-based Wayland compositors.")
+ (license license:expat)))
+
(define-public awesome
(package
(name "awesome")