summaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2017-12-24 10:36:35 +0100
committerRutger Helling <rhelling@mykolab.com>2017-12-24 15:06:32 +0100
commit7866d8c81985ee70ae79e1dbcd22d049e1fd8ba5 (patch)
tree127af0bd2c53c494a0f058c9e73b455333be823d /gnu/packages/wine.scm
parent546f86de169266b1d84560938530808745cdb26a (diff)
downloadguix-patches-7866d8c81985ee70ae79e1dbcd22d049e1fd8ba5.tar
guix-patches-7866d8c81985ee70ae79e1dbcd22d049e1fd8ba5.tar.gz
gnu: Add wine-staging.
* gnu/packages/wine.scm (wine-staging): New variable. Signed-off-by: Rutger Helling <rhelling@mykolab.com>
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index b4f6573cf5..9c99dfd2c4 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -183,3 +183,31 @@ integrate Windows applications into your desktop.")
(base32
"0g6cwjyqwc660w33453aklh3hpc0b8rrb88dryn23ah6wannvagg"))))))
+(define-public wine-staging
+ (package
+ (inherit wine)
+ (name "wine-staging")
+ (version "2.21")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/wine-compholio/wine-patched/archive/"
+ "staging-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pjaxj7h3q6y356np908fvsx0bf7yx5crqvgl4hza6gfssdmsr5r"))))
+ (synopsis "Implementation of the Windows API (staging branch)")
+ (description "Wine-Staging is the testing area of Wine. It
+contains bug fixes and features, which have not been integrated into
+the development branch yet. The idea of Wine-Staging is to provide
+experimental features faster to end users and to give developers the
+possibility to discuss and improve their patches before they are
+integrated into the main branch.")
+ (home-page "https://wine-staging.com")
+ ;; In addition to the regular Wine license (lgpl2.1+), Wine-Staging
+ ;; provides Liberation and WenQuanYi Micro Hei fonts. Those use
+ ;; different licenses. In particular, the latter is licensed under
+ ;; both GPL3+ and Apache 2 License.
+ (license
+ (list license:lgpl2.1+ license:silofl1.1 license:gpl3+ license:asl2.0))))