summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
commit6dffced09ecda024e0884e352778c221ad066fd6 (patch)
tree1707e8d8df4d9c47317a39ab6abbfc2ca66a6c29 /gnu/packages/wget.scm
parentb603554ed044638dd40b6863d5dada59eefe03b8 (diff)
parente3196755e60ba7f1ed9d432e73f26a85e0c8893c (diff)
downloadguix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar
guix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar.gz
Merge branch 'core-updates-frozen' into 'master'.
At last!
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index b537f6fa95..d794bd7bad 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -45,7 +45,7 @@
(define-public wget
(package
(name "wget")
- (version "1.20.3")
+ (version "1.21.1")
(source
(origin
(method url-fetch)
@@ -53,19 +53,17 @@
version ".tar.lz"))
(sha256
(base32
- "1frajd86ds8vz2hprq30wq8ya89z9dcxnwm8nwk12bbc47l7qq39"))))
+ "1bchzkacjsc5c0x01ngaana9fs5j12wfw1c8qxps1yp68x9vx6yv"))))
(build-system gnu-build-system)
(inputs
- `(("gnutls" ,gnutls)
- ("libidn2" ,libidn2)
- ("libpsl" ,libpsl)))
+ (list gnutls libidn2 libpsl))
(native-inputs
- `(("lzip" ,lzip)
- ("pkg-config" ,pkg-config)
- ("perl" ,perl)
- ("python" ,python) ;for testenv suite
- ("perl-http-daemon" ,perl-http-daemon)
- ("perl-io-socket-ssl" ,perl-io-socket-ssl)))
+ (list lzip
+ pkg-config
+ perl
+ python ;for testenv suite
+ perl-http-daemon
+ perl-io-socket-ssl))
(home-page "https://www.gnu.org/software/wget/")
(synopsis "Non-interactive command-line utility for downloading files")
(description
@@ -127,8 +125,7 @@ in downloaded documents to relative links.")
#t))))
#:tests? #f)) ; no test target
(inputs
- `(("wget" ,wget)
- ("xclip" ,xclip)))
+ (list wget xclip))
(home-page "https://wgetpaste.zlin.dk/")
(synopsis "Script that automates pasting to a number of pastebin services")
(description
@@ -171,7 +168,7 @@ online pastebin services.")
("zlib" ,zlib)))
;; TODO: Add libbrotlidec, libnghttp2.
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://gitlab.com/gnuwget/wget2")
(synopsis "Successor of GNU Wget")
(description "GNU Wget2 is the successor of GNU Wget, a file and recursive