summaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
committerLeo Famulari <leo@famulari.name>2017-01-06 17:14:41 -0500
commit74288230ea8b2310495dc2739f39ceadcc143fd0 (patch)
tree73ba6c7c13d59c5f92b409c94dccfff159e08f4d /gnu/packages/wget.scm
parent92e779592d269ca1924f184496eb4ca832997b12 (diff)
parentaa21c764d65068783ae31febee2a92eb3d138a24 (diff)
downloadguix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar
guix-patches-74288230ea8b2310495dc2739f39ceadcc143fd0.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/wget.scm')
-rw-r--r--gnu/packages/wget.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index 80da33272e..72aab86c14 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,3 +61,36 @@ HTTPS and FTP protocols. It can resume interrupted downloads, use file name
wild cards, supports proxies and cookies, and it can convert absolute links
in downloaded documents to relative links.")
(license gpl3+))) ; some files are under GPLv2+
+
+(define-public wgetpaste
+ (package
+ (name "wgetpaste")
+ (version "2.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://wgetpaste.zlin.dk/wgetpaste-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "1hh9svyypqcvdg5mjxyyfzpdzhylhf7s7xq5dzglnm4injx3i3ak"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (zsh (string-append out "/share/zsh/site-functions")))
+ (install-file "wgetpaste" bin)
+ (install-file "_wgetpaste" zsh)))))
+ #:tests? #f)) ; no test target
+ (home-page "http://wgetpaste.zlin.dk/")
+ (synopsis "Script that automates pasting to a number of pastebin services")
+ (description
+ "@code{wgetpaste} is an extremely simple command-line interface to various
+online pastebin services.")
+ (license public-domain)))