summaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-24 19:22:21 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-10-24 19:26:24 +0200
commit2677bf985c0025d04ffdcff31763978b633dbc58 (patch)
treea6a501dffb72ee05a121bafc3e38af64a58bb54c /gnu/packages/webkit.scm
parente38d6a9c2fba815ac34e74baa843f15e33846813 (diff)
downloadguix-patches-2677bf985c0025d04ffdcff31763978b633dbc58.tar
guix-patches-2677bf985c0025d04ffdcff31763978b633dbc58.tar.gz
gnu: webkitgtk-with-libsoup2: Use propagated inputs from GTK3.
This fixes an error in commits ee748c1df093dd63da982e2f3cd0e11c6633d3d6 and 9bac1cad271de4f4436755c296577c4e185d564c, the latter of which was missing a hunk to address the failing build of the former. See <https://bugs.gnu.org/66480#47> for the full patch. * gnu/packages/webkit.scm (webkitgtk-with-libsoup2)[propagated-inputs]: Use package-propagated-inputs from webkitgtk-for-gtk3 rather than webkitgtk. Co-authored-by: Vivien Kraus <vivien@planete-kraus.eu> Change-Id: I3f2bfb127da4021d3b557d15cfdae6d6f54e7935
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 6810ba74e7..7e0370abc0 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -308,7 +308,7 @@ propagated by default) such as @code{gst-plugins-good} and
((#:configure-flags flags)
#~(cons "-DUSE_SOUP2=ON" #$flags))))
(propagated-inputs
- (modify-inputs (package-propagated-inputs webkitgtk)
+ (modify-inputs (package-propagated-inputs webkitgtk-for-gtk3)
(replace "libsoup" libsoup-minimal-2)))))
(define-public wpewebkit