summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:20:09 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:34 +0000
commit5e556a19d21fa4554e6264de5f7cbfea64b5781c (patch)
treeb0135c6caddd0ee2ff29a324afc96dcc8df6c4e3 /gnu/packages/web.scm
parent8b70d436537f9dfbd59808f820b3fb6fd825cbaf (diff)
downloadguix-patches-5e556a19d21fa4554e6264de5f7cbfea64b5781c.tar
guix-patches-5e556a19d21fa4554e6264de5f7cbfea64b5781c.tar.gz
gnu: Add yq.
* gnu/packages/web.scm (yq): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5997cb176d..11bceb1da7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5248,6 +5248,22 @@ processor. It uses @code{jq}-like syntax but works with YAML files as well as
JSON, XML, properties, CSV and TSV.")
(license license:expat)))
+(define-public yq
+ (package
+ (inherit go-github-com-mikefarah-yq-v4)
+ (name "yq")
+ (arguments
+ (list #:install-source? #f
+ #:import-path "github.com/mikefarah/yq/v4"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'rename-binary
+ (lambda _
+ (rename-file (string-append #$output "/bin/v4")
+ (string-append #$output "/bin/yq")))))))
+ (propagated-inputs '())
+ (inputs (package-propagated-inputs go-github-com-mikefarah-yq-v4))))
+
(define-public go-github-com-itchyny-timefmt-go
(package
(name "go-github-com-itchyny-timefmt-go")