summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-05-12 13:29:57 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-05-12 13:29:57 +0530
commit8980f6c5322a8d24b6c7b52f9aaff5eef7e22a5e (patch)
treea9cfe9b1b5eed2c1574a5b8a2b7eb57432a55945 /gnu/packages/web.scm
parenta1a55e5b607bc5ebb3310b5c592f2a2b1161625a (diff)
downloadguix-patches-8980f6c5322a8d24b6c7b52f9aaff5eef7e22a5e.tar
guix-patches-8980f6c5322a8d24b6c7b52f9aaff5eef7e22a5e.tar.gz
gnu: quark: Use G-expressions.
* gnu/packages/web.scm (quark)[arguments]: Rewrite using G-expressions.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5e200d13cc..c56ec186f8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2017, 2018, 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016–2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
@@ -8199,13 +8199,13 @@ Unicode.")
"1znvnr30xi5vgd6n3wvgv9pwj992zpzzjk0fmq28ydf1l6kqvkm7"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; no configure script
+ (list #:tests? #f ; no tests
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://tools.suckless.org/quark/")
(synopsis "Small and simple HTTP GET/HEAD-only web server for static
content")