summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-07-02 16:19:18 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-07-09 13:20:36 +0200
commit582de58c69bd46385196e26434951e1e2d5f32f2 (patch)
treebce830abbedf5acd2404831608919a3c60ec7b0f /gnu/packages/web.scm
parent3c2bbbb0ffcc9b407c81261c1deecd9f043a4509 (diff)
downloadguix-patches-582de58c69bd46385196e26434951e1e2d5f32f2.tar
guix-patches-582de58c69bd46385196e26434951e1e2d5f32f2.tar.gz
gnu: Add anonip.
* gnu/packages/web.scm (anonip): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 124cc93e68..1eae6c7c3b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6498,3 +6499,30 @@ update an existing mirrored site, and resume interrupted downloads.
HTTrack is fully configurable, and has an integrated help system.")
(license license:gpl3+)))
+
+(define-public anonip
+ (package
+ (name "anonip")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "anonip" version))
+ (sha256
+ (base32
+ "0ckn9nnfhpdnz8b92q8pkysdqj6pdh71ckfqvfj0z01cq0hzbhd2"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/DigitaleGesellschaft/Anonip")
+ (synopsis "Anonymize IP addresses in log files")
+ (description
+ "Anonip masks the last bits of IPv4 and IPv6 addresses in log files.
+That way most of the relevant information is preserved, while the IP address
+does not match a particular individuum anymore.
+
+Depending on your Web server, the log entries may be piped to Anonip directly
+or via a FIFO (named pipe). Thus the unmasked IP addresses will never be
+written to any file.
+
+It's also possible to rewrite existing log files.
+
+Anonip can also be uses as a Python module in your own Python application.")
+ (license license:bsd-3)))