summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-09 03:50:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 00:32:35 +0100
commit53846e252b1715bc3af1e7f4fa11f26cd07029bc (patch)
treef5cf2f75238263184b224df62b6275e0eedacd5a /gnu/packages/web.scm
parent4a98f416d6de6d3922e92e3f06305da7207e099b (diff)
downloadguix-patches-53846e252b1715bc3af1e7f4fa11f26cd07029bc.tar
guix-patches-53846e252b1715bc3af1e7f4fa11f26cd07029bc.tar.gz
gnu: stunnel: Use G-expressions.
* gnu/packages/web.scm (stunnel)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 48582b5491..c3821fb325 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5810,23 +5810,24 @@ tools like SSH (Secure Shell) to reach the outside world.")
("python" ,python)))
(inputs (list openssl))
(arguments
- `(#:configure-flags
- (list (string-append "--with-ssl=" (assoc-ref %build-inputs "openssl")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-output-directories
- (lambda _
- ;; Some (not all) Makefiles have a hard-coded incorrect docdir.
- (substitute* (list "Makefile.in"
- "doc/Makefile.in"
- "tools/Makefile.in")
- (("/doc/stunnel")
- (string-append "/doc/" ,name "-" ,version)))))
- (add-after 'install 'prune-documentation
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version)))
- (for-each delete-file (find-files doc "^INSTALL"))))))))
+ (list #:configure-flags
+ #~(list (string-append "--with-ssl="
+ #$(this-package-input "openssl")))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-output-directories
+ (lambda _
+ ;; Some (not all) Makefiles have a hard-coded incorrect docdir.
+ (substitute* (list "Makefile.in"
+ "doc/Makefile.in"
+ "tools/Makefile.in")
+ (("/doc/stunnel")
+ (string-append "/doc/" #$name "-" #$version)))))
+ (add-after 'install 'prune-documentation
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/"
+ #$name "-" #$version)))
+ (for-each delete-file (find-files doc "^INSTALL"))))))))
(home-page "https://www.stunnel.org")
(synopsis "TLS proxy for clients or servers")
(description "Stunnel is a proxy designed to add TLS encryption