summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-02-15 20:54:42 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-16 16:14:26 +0800
commit0205cc298259712454f0f671113c134e27ede776 (patch)
tree306f0a814bece2e88984b1e7bb450718db69d741 /gnu/packages/web.scm
parent2820b1f97e31a08e43ae15d92a389382251aeb4a (diff)
downloadguix-patches-0205cc298259712454f0f671113c134e27ede776.tar
guix-patches-0205cc298259712454f0f671113c134e27ede776.tar.gz
gnu: Add pup.
* gnu/packages/web.scm (pup): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 96d5f8f0b3..0b7e2b299b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4869,6 +4870,33 @@ little effort, and the program to do so is often shorter and simpler than
you'd expect.")
(license (list license:expat license:cc-by3.0))))
+(define-public pup
+ (let ((revision "1")
+ (commit "681d7bb639334bf485476f5872c5bdab10931f9a"))
+ (package
+ (name "pup")
+ (version (git-version "0.4.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ericchiang/pup")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hx1k0qlc1bq6gg5d4yprn4d7kvqzagg6mi5mvb39zdq6c4y17vr"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/ericchiang/pup"))
+ (home-page "https://github.com/ericchiang/pup")
+ (synopsis "Parse HTML at the command line")
+ (description
+ "@command{pup} is a command line tool for processing HTML. It reads
+from stdin, prints to stdout, and allows the user to filter parts of the page
+using CSS selectors. Inspired by @command{jq}, @command{pup} aims to be a
+fast and flexible way of exploring HTML from the terminal.")
+ (license license:expat))))
+
(define-public uhttpmock
(package
(name "uhttpmock")