summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 14:34:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 14:46:45 +0300
commitd30130bcd6c0dfff262d0bcf03175514391d9aa3 (patch)
tree3d65b70f09aebddb841e12da4785de3c822c6f3b /gnu/packages/web.scm
parent990704507be4ec0ef37f4d3e2f319421331fa59c (diff)
downloadguix-patches-d30130bcd6c0dfff262d0bcf03175514391d9aa3.tar
guix-patches-d30130bcd6c0dfff262d0bcf03175514391d9aa3.tar.gz
gnu: libcss: Fix building with gcc-10.
* gnu/packages/web.scm (libcss)[source]: Add snippet to initialize the value of a variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3018dd44bb..23a4130b63 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5387,7 +5387,13 @@ developed as part of the Netsurf project.")
"libcss-" version "-src.tar.gz"))
(sha256
(base32
- "1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))))
+ "1p66sdiiqm7w4jkq23hsf08khsnmq93hshh9f9m8sbirjdpf3p6j"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ (substitute* "src/select/computed.c"
+ (("css_unit unit;") "css_unit unit = CSS_UNIT_PX;"))))))
(build-system gnu-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)