summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-03 22:27:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-04 13:31:33 +0200
commit70c186147f41db28c0308ea008cc11a873645517 (patch)
tree431f5aa7389c72fd9f7ebb12c9b7af0e5045b8be /gnu/packages/web.scm
parent9ef958d8a2437f529a36375504eb4e34c9dceebe (diff)
downloadguix-patches-70c186147f41db28c0308ea008cc11a873645517.tar
guix-patches-70c186147f41db28c0308ea008cc11a873645517.tar.gz
gnu: stunnel: Don't install installation instructions.
* gnu/packages/web.scm (stunnel)[arguments]: Add a 'prune-documentation phase.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index eae03932eb..4e51f4ff35 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5982,7 +5982,12 @@ tools like SSH (Secure Shell) to reach the outside world.")
(("/bin/sh ")
(string-append (which "sh") " ")))
;; This test requires networking.
- (delete-file "tests/recipes/055_socket_closed"))))))
+ (delete-file "tests/recipes/055_socket_closed")))
+ (add-after 'install 'prune-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each delete-file (find-files doc "^INSTALL"))))))))
(home-page "https://www.stunnel.org")
(synopsis "TLS proxy for clients or servers")
(description "Stunnel is a proxy designed to add TLS encryption