summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-12-25 17:36:14 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2020-12-29 21:23:22 +0100
commit9810ed344fac6b04148897399a1a0685047bb7bf (patch)
tree07e78cdaa67ca70d5ae33c3e3f389e08dfc6791b /gnu/packages/web.scm
parentc412900d3e8c59ad59c994fd65634f9aafae1800 (diff)
downloadguix-patches-9810ed344fac6b04148897399a1a0685047bb7bf.tar
guix-patches-9810ed344fac6b04148897399a1a0685047bb7bf.tar.gz
gnu: kiwix-desktop: Fix program start.
Fixes <https://bugs.gnu.org/45404>. * gnu/packages/web.scm (kiwix-desktop)[arguments]: Add phase to wrap QTWEBENGINEPROCESS_PATH. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3693911b88..516cabaa19 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7981,7 +7981,17 @@ It contains the code shared by all Kiwix ports.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "kiwix-desktop.pro"
(("webenginewidgets" all) (string-append all " printsupport")))
- #t)))))
+ #t))
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/kiwix-desktop"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
(inputs
`(("curl" ,curl)
("icu4c" ,icu4c)