summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-19 21:11:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-19 21:11:17 +0100
commitee3f56915e0f4ba9d23384e84122d6009ee80481 (patch)
treef1ed1f00bc82d0b360577498602e403c5eef0978 /gnu/packages/web.scm
parent4d57891027d70de67b0f4a1578a93a413bc0c80b (diff)
downloadguix-patches-ee3f56915e0f4ba9d23384e84122d6009ee80481.tar
guix-patches-ee3f56915e0f4ba9d23384e84122d6009ee80481.tar.gz
gnu: wslay: Fix build.
* gnu/packages/web.scm (wslay)[argument]<#:phases>: Add phase to fix Sphinx error. Fixes <https://issues.guix.gnu.org/52661>.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fff7e48ba3..9442b65439 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1537,7 +1537,15 @@ high performance.")
(build-system gnu-build-system)
(arguments
;; Parallel builds don't reliably succeed.
- `(#:parallel-build? #f))
+ `(#:parallel-build? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-sphinx-error
+ ;; XXX: Remove in next version: fix applied upstream. See
+ ;; <https://github.com/tatsuhiro-t/wslay/commit/43fda1207ea5977043630500e0c8e77b98b35320>.
+ (lambda _
+ (substitute* "doc/sphinx/conf.py.in"
+ (("add_stylesheet") "add_css_file")))))))
(native-inputs
(list autoconf
automake