summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-26 02:01:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-26 02:02:48 +0200
commite598e46913c661bc92df813d537eeb6be5a86471 (patch)
tree44207c0d8c9e885b156bb98562221beb2ab8f7bf /gnu/packages/web.scm
parentb8fc7c23596b542b81306829b31cf255d908fa65 (diff)
downloadguix-patches-e598e46913c661bc92df813d537eeb6be5a86471.tar
guix-patches-e598e46913c661bc92df813d537eeb6be5a86471.tar.gz
gnu: darkhttpd: Update to 1.13.
* gnu/packages/web.scm (darkhttpd): Update to 1.13. [source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dc5a9d61a8..2bd3c4ea13 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5791,28 +5791,28 @@ and similar services.")
(define-public darkhttpd
(package
(name "darkhttpd")
- (version "1.12")
+ (version "1.13")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://unix4lyfe.org/darkhttpd/darkhttpd-"
- version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emikulic/darkhttpd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0185wlyx4iqiwfigp1zvql14zw7gxfacncii3d15yaxk4av1f155"))))
+ (base32 "0w11xq160q9yyffv4mw9ncp1n0dl50d9plmwxb0yijaaxls9i4sk"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("CC=gcc")
#:tests? #f ; No test suite
#:phases
(modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(install-file "darkhttpd"
(string-append (assoc-ref outputs "out")
- "/bin"))
- #t)))))
+ "/bin")))))))
(synopsis "Simple static web server")
(description "darkhttpd is a simple static web server. It is
standalone and does not need inetd or ucspi-tcp. It does not need any