summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/web.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2285f23994..fff7e48ba3 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5927,15 +5927,13 @@ configuration language.")
"0qq5g6bbd1a1ml1wk8jj9z39a899jzqbf7aizr3pvyz0f4kz8mis"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)
-
- ;; For bootstrapping.
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
-
- ;; For generating manuals.
- ("rst2man" ,python-docutils)))
+ (list pkg-config
+ ;; For bootstrapping.
+ autoconf
+ automake
+ libtool
+ ;; For generating manuals.
+ python-docutils))
(inputs
(list python varnish))
(synopsis "Collection of Varnish modules")
@@ -7981,9 +7979,7 @@ tools:
(base32
"1ffzia679axcsccx2fxjpxhb0i5xc42zxn446x6c1170w6v69qf6"))))
(build-system cmake-build-system)
- (native-inputs `(("gtest" ,googletest)
- ("doxygen" ,doxygen)
- ("graphviz" ,graphviz)))
+ (native-inputs (list googletest doxygen graphviz))
(synopsis "Strictly RFC 3986 compliant URI parsing and handling library")
(description "uriparser is a strictly RFC 3986 compliant URI parsing and
handling library written in C89 (\"ANSI C\"). uriparser is fast and supports