summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 21:16:32 +0200
commit8d59c262ada2e2167196a8fb8cbebd9c329a79dd (patch)
tree85a74de8cc23a2f0179c0b9f0adfa4c274449a0c /gnu/packages/web.scm
parente7f0835b07d868fd447aa64c873174fa385e1699 (diff)
parenta068ed6a5f5b3535fce49ac4eca1fec82edd6fdc (diff)
downloadguix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar
guix-patches-8d59c262ada2e2167196a8fb8cbebd9c329a79dd.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/local.mk gnu/packages/algebra.scm gnu/packages/bioinformatics.scm gnu/packages/curl.scm gnu/packages/docbook.scm gnu/packages/emacs-xyz.scm gnu/packages/maths.scm gnu/packages/plotutils.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/radio.scm gnu/packages/readline.scm gnu/packages/tls.scm gnu/packages/xml.scm gnu/packages/xorg.scm
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5d7da25bf2..98a3ce5983 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -249,14 +249,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.47")
+ (version "2.4.48")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "1jh31j4740wz463l1j49ir2lhh42x9z4byiq25m12y75r3dhdl13"))))
+ "0v4npxnvih5mlxx6dywwhhfs8xvgcckc0hxzwk3hi0g8nbkjdj0v"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -318,7 +318,7 @@ Interface} specification.")
(define-public monolith
(package
(name "monolith")
- (version "2.4.1")
+ (version "2.5.0")
(source
(origin
(method git-fetch)
@@ -327,7 +327,7 @@ Interface} specification.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1z0bcvk2cvx2cd0hs8addzcb070xvrkcxvg25691xw0ikiynpkwz"))))
+ (base32 "0s6jyhz51d39ccz0ghr7hy1fww84b0pzsyb8s63qgxbndp2c42l0"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -369,14 +369,14 @@ the same, being completely separated from the Internet.")
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
;; Consider updating the nginx-documentation package together with this one.
- (version "1.19.10")
+ (version "1.21.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "121d11693d6dbim3lh64hrqi66z129z30cvcrpbnm631yl7jkl78"))))
+ "0w87zhm5nfx88x9hj6drrvm5f3m02kzbjp39x1lsglrbmi5jl6gy"))))
(build-system gnu-build-system)
(inputs `(("libxml2" ,libxml2)
("libxslt" ,libxslt)
@@ -467,9 +467,9 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.19.10")
- (revision 2708)
- (changeset "f8686d85df53"))
+ (let ((version "1.21.0")
+ (revision 2726)
+ (changeset "a7a36efd10af"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -481,7 +481,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
(file-name (string-append name "-" version))
(sha256
(base32
- "00b0dkpblw3m2cwbbzv3miw47c0m3s0dvh1xy0hihkggy7mqv2r2"))))
+ "1fl7rkbfdd26c78h85x4w3kas16rpj4pxzjhc071qvx7znwgm2pn"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -2009,7 +2009,7 @@ stylesheets, you'll need to use another program that uses this library,
(define-public sassc
(package
(name "sassc")
- (version "3.6.1")
+ (version "3.6.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2018,7 +2018,7 @@ stylesheets, you'll need to use another program that uses this library,
(file-name (git-file-name name version))
(sha256
(base32
- "1sxm54mkhs9m4vnl7vn11y17mhzamc403hv3966j1c7p2rbzg5pv"))))
+ "0m7flrs0hz3ivib8kvsgn3d0fgkabqviadkp1dyspa6iibx3gjwd"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -2037,9 +2037,9 @@ stylesheets, you'll need to use another program that uses this library,
(("install: libsass-install-\\$\\(BUILD\\) \\\\")
"install: \\"))
#t))
- ;; This phase fails for some reason.
+ ;; This phase fails because…
(delete 'bootstrap)
- ;; There is no configure script.
+ ;; …there is no configure script to be generated.
(delete 'configure)
(add-before 'build 'setup-environment
(lambda _