summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/web.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 940689b4bf..ecb6d68cc1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7679,7 +7679,7 @@ compressed JSON header blocks.
(define-public hpcguix-web
(package
(name "hpcguix-web")
- (version "0.1.0")
+ (version "0.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7688,7 +7688,7 @@ compressed JSON header blocks.
(file-name (git-file-name name version))
(sha256
(base32
- "02lz5k1hhkwfz3nr3lsd69icsz6n0q82z047d3svi09qpxw6y0cj"))))
+ "1l856d1vr63ns1sp9fm6v97p71mx00769k6lwzqzppsb9clksnwp"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -7712,9 +7712,10 @@ compressed JSON header blocks.
(git (assoc-ref inputs "guile-git"))
(bs (assoc-ref inputs "guile-bytestructures"))
(json (assoc-ref inputs "guile-json"))
+ (zlib (assoc-ref inputs "guile-zlib"))
(guile-cm (assoc-ref inputs
"guile-commonmark"))
- (deps (list guile gcrypt git bs guile-cm guix json))
+ (deps (list guile gcrypt git bs zlib guile-cm guix json))
(effective
(read-line
(open-pipe* OPEN_READ
@@ -7739,15 +7740,15 @@ compressed JSON header blocks.
`(("autoconf" ,autoconf)
("automake" ,automake)
("uglify-js" ,uglify-js)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))))
(inputs
`(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
("guix" ,guix)
- ("bash-minimal" ,bash-minimal))) ;for 'wrap-program'
- (propagated-inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guile-zlib" ,guile-zlib)
("guile-commonmark" ,guile-commonmark)
- ("guile-json" ,guile-json-4)))
+ ("guile-json" ,guile-json-4)
+ ("bash-minimal" ,bash-minimal)))
(home-page "https://github.com/UMCUGenetics/hpcguix-web")
(synopsis "Web interface for cluster deployments of Guix")
(description "Hpcguix-web provides a web interface to the list of packages