summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-10-08 19:08:42 -0400
committerLeo Famulari <leo@famulari.name>2021-10-08 19:10:21 -0400
commit2a273e9e2268c24b67620574fe34cc20bce7e5c8 (patch)
treebdaf36fff8c9d90a06786c7df7c16ea270692fca /gnu/packages/web.scm
parentb37fe44b7db3a68f961d07ab010fd1e8220dc50d (diff)
downloadguix-patches-2a273e9e2268c24b67620574fe34cc20bce7e5c8.tar
guix-patches-2a273e9e2268c24b67620574fe34cc20bce7e5c8.tar.gz
gnu: Apache HTTPD: Update to 2.4.51 [fixes CVE-2021-42013].
This fixes CVE-2021-42013, which refers to the incomplete fix of CVE-2021-41773 in httpd 2.4.50: https://httpd.apache.org/security/vulnerabilities_24.html * gnu/packages/web.scm (httpd): Update to 2.4.51.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5819973c66..b2197eceb2 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -252,14 +252,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.50")
+ (version "2.4.51")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "03w9nc7v0rqljxazikbrlgbw7lq72i8n7n9ynlp6h1n6f301fa3a"))))
+ "1x1qp10pfh33x1b56liwsjl0jamjm5lkk7j3lj87c1ygzs0ivq10"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)