summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
commit32cd878be0bb7e153fcaa6f3bfa2632867390ff9 (patch)
treefc1ff93949817c9d172c84d0410ac9225cad57ae /gnu/packages/web.scm
parent753425610274ccb59cce13490c096027c61621d0 (diff)
parent98bd11cfe7b931e9c6d6bf002a8a225fb7a1025b (diff)
downloadguix-patches-32cd878be0bb7e153fcaa6f3bfa2632867390ff9.tar
guix-patches-32cd878be0bb7e153fcaa6f3bfa2632867390ff9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fff4b767ca..8eb4b885bd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -145,6 +145,36 @@ and its related documentation.")
(license l:asl2.0)
(home-page "https://httpd.apache.org/")))
+(define-public mod-wsgi
+ (package
+ (name "mod-wsgi")
+ (version "4.5.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/GrahamDumpleton/mod_wsgi/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0n1yhmrfp8mjbsngmyjl937c6rc0069p6wdi1lknrbn1q42hzw6q"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;; TODO: Can't figure out if there are tests
+ #:make-flags (list
+ (string-append "DESTDIR="
+ (assoc-ref %outputs "out"))
+ "LIBEXECDIR=/modules")))
+ (inputs
+ `(("httpd" ,httpd)
+ ("python" ,python-wrapper)))
+ (synopsis "Apache HTTPD module for Python WSGI applications")
+ (description
+ "The mod_wsgi module for the Apache HTTPD Server adds support for running
+applications that support the Python @acronym{WSGI, Web Server Gateway
+Interface} specification.")
+ (license l:asl2.0)
+ (home-page "https://modwsgi.readthedocs.io/")))
+
(define-public nginx
(package
(name "nginx")