summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-10 19:37:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-12 02:33:54 +0100
commit2772debc747387744287eed9199fcdbd0345f895 (patch)
treeaefb44ef7795a40943793227935485ad018bdaca /gnu/packages/web.scm
parent3e3414efd45d95bbc6320fed75057cb2c82cc3af (diff)
downloadguix-patches-2772debc747387744287eed9199fcdbd0345f895.tar
guix-patches-2772debc747387744287eed9199fcdbd0345f895.tar.gz
gnu: libyajl: Don't use unstable tarball.
* gnu/packages/web.scm (libyajl)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7629353b72..c591ea058a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -786,13 +786,14 @@ style API.")
(name "libyajl")
(version "2.1.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lloyd/yajl/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lloyd/yajl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0nmcqpaiq4pv7dymyg3n3jsd57yhp5npxl26a1hzw3m3lmj37drz"))))
+ "00yj06drb6izcxfxfqlhimlrb089kka0w0x8k27pyzyiq7qzcvml"))))
(build-system cmake-build-system)
(arguments
'(#:phases