summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-01-26 11:35:50 +0100
committerLeo Famulari <leo@famulari.name>2017-01-31 15:06:19 -0500
commit59ae241f7189252c72394fae2e2b85ca61b72755 (patch)
treea2eb3448c63639998c6fd9c8e6bd7b93bc7b7b6e /gnu/packages/web.scm
parent9b11eee955fe788af45c376fb595c259fc4f9c52 (diff)
downloadguix-patches-59ae241f7189252c72394fae2e2b85ca61b72755.tar
guix-patches-59ae241f7189252c72394fae2e2b85ca61b72755.tar.gz
gnu: Add xinetd.
* gnu/packages/web.scm (xinetd): New variable. * gnu/packages/patches/xinetd-CVE-2013-4342.patch, gnu/packages/patches/xinetd-fix-fd-leak.patch: New files. * gnu/local.mk (dist_patch_DATA): Add patches. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 67b9797bbb..cea5b2d27a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3995,3 +3995,28 @@ programs' code. Its architecture is optimized for security, portability, and
scalability (including load-balancing), making it suitable for large
deployments.")
(license l:gpl2+)))
+
+(define-public xinetd
+ (package
+ (name "xinetd")
+ (version "2.3.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "https://github.com/xinetd-org/xinetd/archive/xinetd-2-3-15.tar.gz")
+ (patches (search-patches "xinetd-CVE-2013-4342.patch" "xinetd-fix-fd-leak.patch"))
+ (sha256
+ (base32
+ "0k59x52cbzp5fw0n8zn0y54j1ps0x9b72y8k5grzswjdmgs2a2v2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--with-loadavg")
+ #:tests? #f )) ; no tests
+ (home-page "https://github.com/xinetd-org/xinetd")
+ (synopsis "Internet services daemon")
+ (description "@code{xinetd}, a more secure replacement for @code{inetd},
+listens for incoming requests over a network and launches the appropriate
+service for that request. Requests are made using port numbers as identifiers
+and xinetd usually launches another daemon to handle the request. It can be
+used to start services with both privileged and non-privileged port numbers.")
+ (license (l:fsf-free "file://COPYRIGHT"))))