summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-02 21:40:16 -0500
committerLeo Famulari <leo@famulari.name>2018-01-03 00:34:03 -0500
commit7526338837baf4d6ceef922b09df6967ff3aa6ec (patch)
treeb4766f90d7a866099168636ffa2cc7299f411db0 /gnu/packages/web.scm
parent48a716c484c45594de86aa91c2ba5e80eb931a63 (diff)
downloadguix-patches-7526338837baf4d6ceef922b09df6967ff3aa6ec.tar
guix-patches-7526338837baf4d6ceef922b09df6967ff3aa6ec.tar.gz
gnu: httpd: Update to 2.4.29.
* gnu/packages/web.scm (httpd): Update to 2.4.29. [source]: Remove patch. * gnu/packages/patches/httpd-CVE-2017-9798.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c8ad735423..a0d9e7a329 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -109,15 +109,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.27")
+ (version "2.4.29")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "0fn1778mxhf78np2d8qlycg1c2ak18rxax41plahasca4clc3z3i"))
- (patches (search-patches "httpd-CVE-2017-9798.patch"))))
+ "003z3yckkdihfv69rgqsik1w2jsnh14j3ci8fjia4s2mlajm6xvp"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)