summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-27 17:48:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-27 17:58:43 +0200
commitdecb4c26fa1c748b118e33495d5493d84a6ca6c9 (patch)
treec603285594e971162db75a5769aef4fcc5514db4 /gnu/packages/web.scm
parent0d29f5aac536f556e1b4b0f967b138cbe0bc5aaa (diff)
downloadguix-patches-decb4c26fa1c748b118e33495d5493d84a6ca6c9.tar
guix-patches-decb4c26fa1c748b118e33495d5493d84a6ca6c9.tar.gz
gnu: serf: Disable expired SSL tests.
Fixes <https://bugs.gnu.org/26671>. * gnu/packages/web.scm (serf)[arguments]<#:phases>: Add 'disable-broken-tests'.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index cb9912e0a2..5c82cd575e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -861,6 +862,33 @@ from streaming URLs. It is a command-line wrapper for the libquvi library.")
;;(string-append "GSSAPI=" gss)
(string-append "ZLIB=" zlib)
(string-append "PREFIX=" out))))))
+ (add-before 'check 'disable-broken-tests
+ (lambda _
+ ;; These tests rely on SSL certificates that expired 2017-04-18.
+ ;; While there are newer certs available upstream, we don't want
+ ;; this package to suddenly "expire" some time in the future.
+ ;; https://bugs.gnu.org/26671
+ (let ((broken-tests
+ '("test_ssl_trust_rootca"
+ "test_ssl_certificate_chain_with_anchor"
+ "test_ssl_certificate_chain_all_from_server"
+ "test_ssl_no_servercert_callback_allok"
+ "test_ssl_large_response"
+ "test_ssl_large_request"
+ "test_ssl_client_certificate"
+ "test_ssl_future_server_cert"
+ "test_setup_ssltunnel"
+ "test_ssltunnel_basic_auth"
+ "test_ssltunnel_basic_auth_server_has_keepalive_off"
+ "test_ssltunnel_basic_auth_proxy_has_keepalive_off"
+ "test_ssltunnel_basic_auth_proxy_close_conn_on_200resp"
+ "test_ssltunnel_digest_auth")))
+ (for-each
+ (lambda (test)
+ (substitute* "test/test_context.c"
+ (((string-append "SUITE_ADD_TEST\\(suite, " test "\\);")) "")))
+ broken-tests)
+ #t)))
(replace 'check (lambda _ (zero? (system* "scons" "check"))))
(replace 'install (lambda _ (zero? (system* "scons" "install")))))))
(home-page "https://serf.apache.org/")