summaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-08 22:43:23 +0100
committerMarius Bakke <marius@gnu.org>2023-01-09 08:55:09 +0100
commit37aeb85f45ad2d3163e206e127d7b4cefc8b0533 (patch)
tree13c5c6ead4431fd593d9282e3519be2a825262b7 /gnu/packages/web.scm
parent1efe7de0966afe1b96d7e8472d17a9c6142b5043 (diff)
downloadguix-patches-37aeb85f45ad2d3163e206e127d7b4cefc8b0533.tar
guix-patches-37aeb85f45ad2d3163e206e127d7b4cefc8b0533.tar.gz
gnu: ikiwiki: Add missing inputs.
This fixes a regression from a1f9eba892784069e34338e01237a74b8a3bd8a2 whereby loading po4a as a library fails. * gnu/packages/web.scm (ikiwiki)[inputs]: Add PERL-SYNTAX-KEYWORD-TRY and PERL-XS-PARSE-KEYWORD.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dcb7b3872a..eb9635f6ee 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017, 2018, 2020, 2021, 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2017-2018, 2020-2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017, 2021 Pierre Langlois <pierre.langlois@gmx.com>
@@ -5249,6 +5249,12 @@ NetSurf project.")
("perl-xml-sax" ,perl-xml-sax)
("perl-xml-twig" ,perl-xml-twig)
("perl-yaml-tiny" ,perl-yaml-tiny)
+
+ ;; Ikiwiki loads po4a as a library, and thus needs the po4a dependencies
+ ;; available. Duplicate them here.
+ ;; XXX: It would be ideal to hard code these in po4a somehow.
+ ("perl-syntax-keyword-try" ,perl-syntax-keyword-try)
+ ("perl-xs-parse-keyword" ,perl-xs-parse-keyword)
("po4a" ,po4a)))
(propagated-inputs
(list perl-cgi-formbuilder