summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorAndre A. Gomes <andremegafone@gmail.com>2024-01-22 15:31:48 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-24 11:18:02 +0100
commit90f9528748db5edc8df20dc4c625fd6ad1a55b8f (patch)
treef353ec061c25c769728d16530ceec30d5e1a4e63 /gnu/packages/web-browsers.scm
parent8aa3ae15dd228509646a360afd977701726f1850 (diff)
downloadguix-patches-90f9528748db5edc8df20dc4c625fd6ad1a55b8f.tar
guix-patches-90f9528748db5edc8df20dc4c625fd6ad1a55b8f.tar.gz
gnu: nyxt: Update to 3.11.1.
* gnu/packages/web-browsers.scm (nyxt): Update to 3.11.1. [inputs]: Remove sbcl-fset and sbcl-mk-string-metrics. Add gst-libav, gst-plugins-bad, gst-plugins-base, gst-plugins-good, gst-plugins-ugly. [arguments]: Update 'configure-tests' phase. [home-page]: Update URL. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Change-Id: If35d6f0153339b311057bea05562fefb215c3f0d
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 71289dbb2b..ba95fcecba 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnome-xyz)
#:use-module (gnu packages gnupg)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
@@ -589,7 +590,7 @@ driven and does not detract you from your daily work.")
(define-public nyxt
(package
(name "nyxt")
- (version "3.11.0")
+ (version "3.11.1")
(source
(origin
(method git-fetch)
@@ -598,7 +599,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0hzkpk8kshw7afz3pryi99xz2vg3v676day0mgji3hvaazfan39p"))
+ "107zsjpwhdiafgj55zdbqj6qwyvpfcdf8vxn16sry16r2jaxxagf"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
@@ -610,14 +611,9 @@ driven and does not detract you from your daily work.")
(modify-phases %standard-phases
(delete 'configure)
(add-before 'build 'fix-common-lisp-cache-folder
- (lambda _
- (setenv "HOME" "/tmp")
- #t))
+ (lambda _ (setenv "HOME" "/tmp")))
(add-before 'check 'configure-tests
- (lambda _
- (setenv "NYXT_TESTS_NO_NETWORK" "1")
- (setenv "NYXT_TESTS_ERROR_ON_FAIL" "1")
- #t))
+ (lambda _ (setenv "NYXT_TESTS_NO_NETWORK" "1") #t))
(add-after 'install 'wrap-program
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
@@ -639,8 +635,7 @@ driven and does not detract you from your daily work.")
(,(string-append glib-networking "/lib/gio/modules")))
`("GI_TYPELIB_PATH" prefix (,gi-path))
`("LD_LIBRARY_PATH" ":" prefix (,path))
- `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
- #t))))))
+ `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))))))))
(native-inputs (list cl-lisp-unit2 sbcl))
(inputs (list sbcl-alexandria
sbcl-bordeaux-threads
@@ -665,14 +660,12 @@ driven and does not detract you from your daily work.")
sbcl-dissect
sbcl-enchant
sbcl-flexi-streams
- sbcl-fset
sbcl-history-tree
sbcl-iolib
sbcl-lass
sbcl-local-time
sbcl-log4cl
sbcl-lparallel
- sbcl-mk-string-metrics
sbcl-montezuma
sbcl-moptilities
sbcl-named-readtables
@@ -710,9 +703,15 @@ driven and does not detract you from your daily work.")
gtk+ ; For the main loop
webkitgtk-for-gtk3 ; Required when we use its typelib
gobject-introspection
- pkg-config))
+ pkg-config
+ ;; Useful for video playback
+ gst-libav
+ gst-plugins-bad
+ gst-plugins-base
+ gst-plugins-good
+ gst-plugins-ugly))
(synopsis "Extensible web-browser in Common Lisp")
- (home-page "https://nyxt.atlas.engineer")
+ (home-page "https://nyxt-browser.com/")
(description "Nyxt is a keyboard-oriented, extensible web-browser designed
for power users. The application has familiar Emacs and VI key-bindings and
is fully configurable and extensible in Common Lisp.")