summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-26 16:42:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-26 17:30:10 +0300
commit7fb0207aa22330b80294bb5d49fb6907458ce5a0 (patch)
treed80ef606e08692483015b04d188973aab993ef8d /gnu/packages/web-browsers.scm
parenta8f402370555c8437e1e239292fb00a64f9a07d5 (diff)
downloadguix-patches-7fb0207aa22330b80294bb5d49fb6907458ce5a0.tar
guix-patches-7fb0207aa22330b80294bb5d49fb6907458ce5a0.tar.gz
gnu: qutebrowser: Install more scripts.
* gnu/packages/web-browsers.scm (qutebrowser)[arguments]: Rewrite cutsom 'install-more phase to use included makefile.
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm25
1 files changed, 6 insertions, 19 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 31504fe2af..b12582dfed 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -504,25 +504,12 @@ interface.")
(setenv "QT_QPA_PLATFORM" "offscreen")))
(add-after 'install 'install-more
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (app (string-append out "/share/applications"))
- (hicolor (string-append out "/share/icons/hicolor")))
- (install-file "doc/qutebrowser.1"
- (string-append out "/share/man/man1"))
- (for-each
- (lambda (i)
- (let ((src (format #f "icons/qutebrowser-~dx~d.png" i i))
- (dest (format #f "~a/~dx~d/apps/qutebrowser.png"
- hicolor i i)))
- (mkdir-p (dirname dest))
- (copy-file src dest)))
- '(16 24 32 48 64 128 256 512))
- (install-file "icons/qutebrowser.svg"
- (string-append hicolor "/scalable/apps"))
- (substitute* "misc/org.qutebrowser.qutebrowser.desktop"
- (("Exec=qutebrowser")
- (string-append "Exec=" out "/bin/qutebrowser")))
- (install-file "misc/org.qutebrowser.qutebrowser.desktop" app))))
+ (let ((out (assoc-ref outputs "out")))
+ (rename-file "misc/Makefile" "Makefile")
+ (substitute* "Makefile"
+ ((".*setup\\.py.*") ""))
+ (invoke "make" "install" (string-append "PREFIX=" out))
+ (delete-file-recursively (string-append out "/share/metainfo")))))
(add-after 'wrap 'wrap-qt-process-path
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))