summaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/web-browsers.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar
guix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index ff11366d06..b327338cd5 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -159,14 +159,14 @@ management, extensions such as advertisement blocker and colorful tabs.")
(define-public links
(package
(name "links")
- (version "2.26")
+ (version "2.27")
(source (origin
(method url-fetch)
(uri (string-append "http://links.twibright.com/download/"
"links-" version ".tar.bz2"))
(sha256
(base32
- "1jy90k04kl7y3l8jzg5jx7fglyqzngng0964j7j67gjxy9vkanzh"))))
+ "1d7bz6bbis94jq82xydwnazaczzmb1ij62pbmf0dxkg7xpycppfq"))))
(build-system gnu-build-system)
(arguments
(list
@@ -708,7 +708,7 @@ is fully configurable and extensible in Common Lisp.")
(define-public lagrange
(package
(name "lagrange")
- (version "1.12.1")
+ (version "1.13.6")
(source
(origin
(method url-fetch)
@@ -716,13 +716,14 @@ is fully configurable and extensible in Common Lisp.")
(string-append "https://git.skyjake.fi/skyjake/lagrange/releases/"
"download/v" version "/lagrange-" version ".tar.gz"))
(sha256
- (base32 "10v4bp5h1qq24by61yw52rr13m23smfj2whxfzcxc34qgsdjsd4a"))
+ (base32 "19xaw6lspl4mjx1wls0s15l97dzfkv20gph652yzwk6ia3ly92bs"))
(modules '((guix build utils)))
(snippet
'(begin
;; TODO: unbundle fonts.
(delete-file-recursively "lib/fribidi")
- (delete-file-recursively "lib/harfbuzz")))))
+ (delete-file-recursively "lib/harfbuzz")
+ (delete-file-recursively "lib/sealcurses")))))
(build-system cmake-build-system)
(arguments
`(#:tests? #false ;no tests
@@ -924,14 +925,14 @@ interface.")
(define-public telescope
(package
(name "telescope")
- (version "0.7.1")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/omar-polo/telescope/releases/download/"
version "/telescope-" version ".tar.gz"))
(sha256
- (base32 "055iqld99l4jshs10mhl2ml0p74wcyyv5kxjy8izzysw9lnkjjb5"))))
+ (base32 "1fblm3mjddhjmcj1c065n9440n72ld037bdjdlyk1fpwd240m1pa"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f)) ;no tests
@@ -939,7 +940,7 @@ interface.")
(list gettext-minimal pkg-config))
(inputs
(list libevent libressl ncurses))
- (home-page "https://git.omarpolo.com/telescope/about/")
+ (home-page "https://telescope.omarpolo.com/")
(synopsis "Gemini client with a terminal interface")
(description "Telescope is a w3m-like browser for Gemini.")
(license license:x11)))