summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorIvan Kozlov <kanichos@yandex.ru>2020-06-14 11:48:59 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-14 11:53:45 +0200
commit8331e2357b67e1b6b2f43ccaf904d7752e124645 (patch)
treec98b2b8aba4a7f5b9dafb25bb8bd2506e604fba7 /gnu/packages/vpn.scm
parentd291b454bd402c88eed1464a1dfa058a2f663874 (diff)
downloadguix-patches-8331e2357b67e1b6b2f43ccaf904d7752e124645.tar
guix-patches-8331e2357b67e1b6b2f43ccaf904d7752e124645.tar.gz
gnu: xl2tpd: Add pppd support.
* gnu/packages/vpn.scm (xl2tpd)[inputs]: Add "linux-libre-headers" and "ppp", [arguments]: add a 'setup-environment phase to set "PPPD" and "KERNELSRC" variables. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a0aff7a32c..4a26ced824 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,6 +58,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages python-web)
+ #:use-module (gnu packages samba)
#:use-module (gnu packages tls)
#:use-module (gnu packages xml))
@@ -643,9 +645,20 @@ public keys and can roam across IP addresses.")
`(#:make-flags (list (string-append "PREFIX=" %output)
"CC=gcc")
#:phases (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
+ (delete 'configure) ;no configure script
+ (add-before 'build 'setup-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CFLAGS"
+ (string-append "-DPPD=\""
+ (assoc-ref inputs "ppp")
+ "/sbin/pppd\""))
+ (setenv "KERNELSRC"
+ (assoc-ref inputs "linux-libre-headers"))
+ #t)))
#:tests? #f)) ; no tests provided
- (inputs `(("libpcap" ,libpcap)))
+ (inputs `(("libpcap" ,libpcap)
+ ("linux-libre-headers" ,linux-libre-headers)
+ ("ppp" ,ppp)))
(home-page "https://www.xelerance.com/software/xl2tpd/")
(synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
(description