summaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-07 22:26:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-07 22:26:55 +0200
commit9bd1333e587c92fb3f0c12e080cb89e41713df01 (patch)
treef053e0174c052df046ef2ad320bcc5cdc8c76b01 /gnu/packages/vpn.scm
parent378d94e51b00c30b19a39154278d01f1f3c4dbc1 (diff)
parent55e238f2ab24ce347047ebc7fd7c5eba62dac69d (diff)
downloadguix-patches-9bd1333e587c92fb3f0c12e080cb89e41713df01.tar
guix-patches-9bd1333e587c92fb3f0c12e080cb89e41713df01.tar.gz
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index c7046b7f50..d1a7248536 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
-;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
@@ -227,11 +227,6 @@ the entire VPN in a network namespace accessible only through SSH.")
("automake" ,automake)))
(inputs
`(("libevent" ,libevent)))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _ (invoke "sh" "autogen.sh"))))))
(home-page "https://github.com/cernekee/ocproxy")
(synopsis "OpenConnect proxy")
(description
@@ -252,11 +247,12 @@ the user specifically asks to proxy, so the @dfn{VPN} interface no longer
(sha256 (base32
"1wlypi68kqqg2mdck8wvf6aanhrmf9i7z6lngyxvcrp23jdzz34h"))))
(build-system gnu-build-system)
- (inputs
+ (propagated-inputs
`(("libxml2" ,libxml2)
("gnutls" ,gnutls)
- ("vpnc-scripts" ,vpnc-scripts)
("zlib" ,zlib)))
+ (inputs
+ `(("vpnc-scripts" ,vpnc-scripts)))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))