summaryrefslogtreecommitdiff
path: root/gnu/packages/virtualization.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-18 08:46:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-09-19 23:22:45 -0400
commitafeed71ae447ea18f7bc1b0b331e73e995308251 (patch)
tree1089150b27dd81891933152e72f391ab8d29e9f4 /gnu/packages/virtualization.scm
parentd5d80a62b72353300b3a3e52f02b5ff12a6c2dea (diff)
downloadguix-patches-afeed71ae447ea18f7bc1b0b331e73e995308251.tar
guix-patches-afeed71ae447ea18f7bc1b0b331e73e995308251.tar.gz
gnu: qemu: Disable the bios-tables-test test.
This works around <https://issues.guix.info/43048>. * gnu/packages/virtualization.scm (qemu)[phases]{disable-unusable-tests}: Move after unpack. Combine the existing substitute patterns on a single usage of substitute*. Disable the bios-tables-test test in tests/qtest/Makefile.include.
Diffstat (limited to 'gnu/packages/virtualization.scm')
-rw-r--r--gnu/packages/virtualization.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index cf7380268f..9955045efb 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -179,6 +179,24 @@
'("include")
input-directories)
#t)))
+ (add-after 'unpack 'disable-unusable-tests
+ (lambda _
+ (substitute* "tests/Makefile.include"
+ ;; Comment out the test-qga test, which needs /sys and
+ ;; fails within the build environment.
+ (("check-unit-.* tests/test-qga" all)
+ (string-append "# " all))
+ ;; Comment out the test-char test, which needs networking and
+ ;; fails within the build environment.
+ (("check-unit-.* tests/test-char" all)
+ (string-append "# " all)))
+ (substitute* "tests/qtest/Makefile.include"
+ ;; Disable the following test, which triggers a crash on some
+ ;; x86 CPUs (see https://issues.guix.info/43048 and
+ ;; https://bugs.launchpad.net/qemu/+bug/1896263).
+ (("check-qtest-i386-y \\+= bios-tables-test" all)
+ (string-append "# " all)))
+ #t))
(add-after 'patch-source-shebangs 'patch-/bin/sh-references
(lambda _
;; Ensure the executables created by these source files reference
@@ -243,19 +261,6 @@
exec smbd $@")))
(chmod "samba-wrapper" #o755)
(install-file "samba-wrapper" libexec))
- #t))
- (add-before 'check 'disable-unusable-tests
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "tests/Makefile.include"
- ;; Comment out the test-qga test, which needs /sys and
- ;; fails within the build environment.
- (("check-unit-.* tests/test-qga" all)
- (string-append "# " all)))
- (substitute* "tests/Makefile.include"
- ;; Comment out the test-char test, which needs networking and
- ;; fails within the build environment.
- (("check-unit-.* tests/test-char" all)
- (string-append "# " all)))
#t)))))
(inputs ; TODO: Add optional inputs.
`(("alsa-lib" ,alsa-lib)