summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-04-06 22:56:07 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-04-06 22:57:48 +0300
commit3ac90f92a0ba147e555a548e2bd077f5533b7a8c (patch)
treef2c2a7abcb5c908706b34b76623c634659293e3e /gnu/packages/vim.scm
parentc2125e59d0774cda3e559adeb056459a5f23586b (diff)
downloadguix-patches-3ac90f92a0ba147e555a548e2bd077f5533b7a8c.tar
guix-patches-3ac90f92a0ba147e555a548e2bd077f5533b7a8c.tar.gz
gnu: vim: Update to 8.2.4701.
* gnu/packages/vim.scm (vim): Update to 8.2.4701. [arguments]: Adjust custom 'skip-or-fix-failing-tests phase to skip another test.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index bc5e36c6f2..7279798fe6 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -77,7 +77,7 @@
(define-public vim
(package
(name "vim")
- (version "8.2.4564")
+ (version "8.2.4701")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -86,7 +86,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "1ggvmvd6xsj9xvknjcvpj52na2km2wxvxfj8l29mqp03g4wwyzrr"))))
+ "0yqqzai3ihfjjjjmn50pxlcqllpkmlrf5z59ma5rn0gv8wwwdw7h"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -118,6 +118,11 @@
(setenv "TERM" "xterm")))
(add-before 'check 'skip-or-fix-failing-tests
(lambda _
+ ;; This test failure is shared between BSD and Guix.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "src/testdir/test_writefile.vim"
+ (("!has\\('bsd'\\)") "0")))
+
;; This test assumes that PID 1 is run as root and that the user
;; running the test suite does not have permission to kill(1, 0)
;; it. This is not true in the build container, where both PID 1