summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorIvan Kozlov <kanichos@yandex.ru>2020-11-01 15:27:37 +0300
committerMarius Bakke <marius@gnu.org>2020-11-10 22:32:13 +0100
commita172a646d8727bde2a568d5a721a9f5789973442 (patch)
tree802af6466cf2f09f87d6bd3d7b4620a26e984f62 /gnu/packages/video.scm
parent8090c24b856e1f1fc187badc039cebb66ba5460a (diff)
downloadguix-patches-a172a646d8727bde2a568d5a721a9f5789973442.tar
guix-patches-a172a646d8727bde2a568d5a721a9f5789973442.tar.gz
gnu: v4l-utils: Move graphical tools to a separate output
v4l-utils is a common dependency. Separate graphical tools to avoid pulling in qtbase unless they are referenced. * gnu/packages/video.scm (v4l-utils)[outputs]: New 'gui' output. [arguments]: Add 'split' phase. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index b3926af8bb..0188d15914 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2987,11 +2988,39 @@ tools, XML authoring components, and an extensible plug-in based API.")
(base32
"1bkqlrizx0j2rd6ybam2x17bjrpwzl4v4szmnzm3cmixis3w3npr"))))
(build-system gnu-build-system)
+ ;; Separate graphical tools in order to save almost 1 GiB on the closure
+ ;; for the common case.
+ (outputs '("out" "gui"))
(arguments
'(#:configure-flags
(list (string-append "--with-udevdir="
(assoc-ref %outputs "out")
- "/lib/udev"))))
+ "/lib/udev"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'split
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gui (assoc-ref outputs "gui")))
+ (mkdir-p (string-append gui "/bin"))
+ (mkdir-p (string-append gui "/share/man/man1"))
+ (mkdir-p (string-append gui "/share/applications"))
+ (for-each
+ (lambda (prog)
+ (for-each
+ (lambda (file)
+ (rename-file (string-append out file)
+ (string-append gui file)))
+ (list
+ (string-append "/bin/" prog)
+ (string-append "/share/man/man1/" prog ".1")
+ (string-append "/share/applications/" prog ".desktop"))))
+ '("qv4l2" "qvidcap"))
+ (copy-recursively (string-append out "/share/icons")
+ (string-append gui "/share/icons"))
+ (delete-file-recursively (string-append out "/share/icons"))
+ (rmdir (string-append out "/share/applications"))
+ #t))))))
(native-inputs
`(("perl" ,perl)
("pkg-config" ,pkg-config)))